Partilhar via


Erro AADSTS70001 – O aplicativo com identificador não encontrado no diretório

Este artigo descreve um problema no qual você recebe a mensagem de erro "Erro AADSTS70001 - O aplicativo com identificador não foi encontrado no diretório." ao tentar entrar em um aplicativo configurado de logon único (SSO) baseado em SAML que foi integrado à ID do Microsoft Entra.

Sintomas

Você recebe um erro AADSTS70001 ao tentar entrar em um aplicativo que foi configurado para usar a ID do Microsoft Entra para gerenciamento de identidades usando o SSO baseado em SAML.

Motivo

O Issuer atributo enviado do aplicativo para a ID do Microsoft Entra na solicitação SAML não corresponde ao valor do Identificador configurado para o aplicativo na ID do Microsoft Entra.

Resolução

Verifique se o Issuer atributo na solicitação SAML corresponde ao valor do Identificador configurado na ID do Microsoft Entra.

Na página configuração do SSO baseado em SAML, na seção Configuração SAML básico, verifique se o valor na caixa de texto Identificador corresponde ao valor do identificador exibido no erro. Se houver uma barra final no final do url, ela também deve ser incluída.

Usando a função SSO de teste no centro de administração do Microsoft Entra

O centro de administração do Microsoft Entra pode ajudá-lo a solucionar erros de configuração do SAML.

Captura de tela do recurso de teste de SSO no centro de administração do Microsoft Entra.

  1. No centro de administração do Microsoft Entra, vá para Aplicativos Empresariais e clique no aplicativo que precisa de solução de problemas.
  2. Navegue até a página Logon único usando o menu de navegação à esquerda
  3. Clique em Testar este aplicativo para usar a funcionalidade Testar SSO.
  4. Copie e cole o erro recebido na seção Resolução de erros e clique em Obter orientação de resolução
  5. Veja a diferença entre o emissor e o identificador encontrados.
  6. Corrija o emissor ou o identificador.

Mais informações

Para obter uma lista completa de códigos de erro de autenticação e autorização do Active Directory, consulte Códigos de erro de autenticação e autorização do Microsoft Entra

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.