A exclusão de SLAs ou itens de SLA mostra um erro na Interface Unificada durante uma atualização de solução ou exclusão manual
Este artigo fornece uma resolução para o problema em que a exclusão de SLAs (contratos de nível de serviço) ou itens de SLA mostra uma mensagem de erro na Interface Unificada durante uma atualização de solução ou exclusão manual.
Sintomas
Quando você tenta excluir SLAs ou itens de SLA durante um upgrade de solução ou exclusão manual, ocorre uma das seguintes mensagens de erro:
O objeto que você tentou excluir está associado a outro objeto e não pode ser excluído.
SLAItem delete encontrou alguns erros. O processo faz parte de uma solução gerenciada e não pode ser excluído individualmente. Desinstale a solução primária para remover o processo. Consulte log para obter mais detalhes.
Motivo
A primeira mensagem de erro ocorre porque, no SLA da Interface Unificada, a relação entre o item de SLA e as instâncias de KPI de SLA é definida como "Restringir à Exclusão". A segunda mensagem de erro ocorre porque os processos que fazem parte de uma solução gerenciada não podem ser excluídos. Se você tentar excluir manualmente um SLA que faça parte de uma solução gerenciada e tenha fluxos configurados, a mensagem de erro será exibida.
Resolução 1
Em vez de excluir o SLA, desative o SLA em sua organização. Se fizer parte de uma solução gerenciada, execute as seguintes etapas:
- Desative o SLA na instância de origem e adicione-o à solução.
- Desative o mesmo SLA na instância de destino e aplique a atualização da solução.
Resolução 2
Primeiro, você pode excluir manualmente todos os registros de entidade relacionados ao SLA e as instâncias de KPI do SLA e, em seguida, remover o SLA. Aqui estão as etapas para fazer isso:
- Em sua organização, vá para Localização Avançada, pesquise Instâncias de KPI de SLA e selecione SLAItem.
- Selecione Resultado. As instâncias de KPI de SLA serão listadas.
- Selecione as instâncias de KPI de SLA necessárias e, em seguida, selecione Excluir SLAKPIInstances. Isso também anulará as instâncias de KPI de SLA nos registros relacionados.
Mesmo depois de excluir os registros de referência, se a mensagem de erro "SLAItem delete operation encontrou alguns erros. O processo faz parte de uma solução gerenciada e não pode ser excluído individualmente. Desinstale a solução primária para remover o processo. Consulte log para obter mais detalhes" mostra e, em seguida, aplique a atualização da solução com o SLA excluído da solução de atualização.
Resolução 3
Se a resolução acima não funcionar, entre em contato com o Suporte da Microsoft para solicitar a exclusão do SLA ou dos itens do SLA.