Aracılığıyla paylaş


KMS etkinleştirmesinde "0xC004F038: Bilgisayar etkinleştirilemedi" hatası

Bu makale Kıdemli Destek Yükseltme Mühendisi Eric Ashton tarafından yazılmıştır.

Belirtiler

Aşağıdaki yöntemlerden herhangi birini kullanarak Microsoft Office 2013 veya Office 2016'yi Anahtar Yönetimi Hizmeti (KMS) konağı aracılığıyla etkinleştirmeye çalışırsınız:

  • Toplu Etkinleştirme Yönetim Aracı (VAMT)
  • İstemci bilgisayardan Office etkinleştirme sihirbazı
  • /act betiğini OSPP.vbs

Ancak, aşağıdaki hata iletisini alırsınız:

0xC004F038: Yazılım Lisanslama Hizmeti, bilgisayarın etkinleştirilmediğini bildirdi. Anahtar Yönetimi Hizmetiniz (KMS) tarafından bildirilen sayı yetersiz. Lütfen sistem yöneticinize başvurun.

Neden

Bu sorun, Office KMS havuzu beşten az benzersiz istemci bilgisayar içerdiğinden oluşur.

Çözüm

Bu sorunu çözmek için, Office KMS havuzundaki istemci bilgisayar sayısını beş veya daha fazla olarak artırın.

Not

KMS konağındaki Office KMS havuzunda şu anda kaç istemci bilgisayar olduğunu belirlemek için, c:\windows\system32'den yükseltilmiş bir Komut İstemi penceresinde aşağıdaki komutu çalıştırın ve enter tuşuna basın:

Cscript slmgr.vbs -dlv all >c:\temp\KMSInfo.txt

c:\temp (veya çıkışı yerleştirdiğiniz herhangi bir özel konuma) gidin ve KMSInfo.txt açın. Office KMS ana bilgisayar yükleme ayrıntılarınızı bulmak için Office'i arayın. Geçerli Sayı değerini denetleyin. Office KMS sayısı değeri 5'ten küçükse, Office istemcileri etkinleştirilmez.

Office KMS havuzu beş veya daha fazla istemci bilgisayar içeriyorsa, Office etkinleştirme sihirbazını, OSPP.vbsveya VAMT'yi kullanarak Office'i etkinleştirmeyi deneyin.

Ortamınızda Sistem Hazırlığı (Sysprep) kullanıyorsanız, resim oluşturmadan önce Office'in yeniden oluşturulmamış olması mümkündür. Bu nedenle, bilgisayarlar Office için aynı istemci bilgisayar kimliğine (CMID) sahip olabilir.

Etkinleştirmeye çalışan beşten fazla bilgisayarınız varsa ve yine de bu hata iletisini görüyorsanız KMS sunucusunda KMS ana bilgisayar oturum açma Olay Görüntüleyicisi denetleyin. Örneğin, aşağıdakine benzer girdiler görürsünüz:

  • 0x0,5,Ignite1.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37,Tarih/Saat,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite2.ignite.local,2f362dd3-fb39-4d18-94e6-de1d30dd27d5,Tarih/Saat,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite5.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37,Tarih/Saat,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c

Bu örnekte, Ignite5 ve ignite1'in aynı CMID'ye (930bd202-a335-4c7e-bd9d-7305361f0d37) sahip olduğuna dikkat edin. Bu, temel işletim sistemi görüntüsü oluşturulmuş olsa bile Office arka görüntüsünün atlandığını gösterir.

Not

Sysprep görüntüyü hazırlamadan önce, benzersiz bir Office CMID'sini garanti etmek için Office bit sürümünüz temelinde aşağıdaki komutlardan birini çalıştırdığınızdan emin olun.

  • 32 bit Office için

    C:\Program Files (x86)\Microsoft Office\Office16\ospprearm.exe

  • 64 bit Office için

    C:\Program Files\Microsoft Office\Office16\ospprearm.exe

Office yüklemesini yeniden oluşturma hakkında ayrıntılı bilgi için aşağıdaki makalelere bakın:

Office'i yeniden oluşturmak ve yeni, benzersiz Office kimlikleri oluşturmak için bu bilgisayarlarda aşağıdaki başlangıç betiğini çalıştırabilirsiniz. Bu betikte, Office sürümünüz temelinde XX değerini uygun değerle değiştirin:

XX = Office 2013 için 15

XX = Office 2016 için 16

@echo off

:OSPP 

reg query HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM if %errorlevel%==1 (goto RUN) else (goto END)

:RUN set ProgramFilesPath=%ProgramFiles% 

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act set ProgramFilesPath=%ProgramFiles(x86)%

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act REG ADD "HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM"

:END

Exit