Aracılığıyla paylaş


SharePoint veya OneDrive'da site kullanıcı kimliği uyuşmazlığı düzeltilir

Belirtiler

Kuruluşunuzdaki kullanıcılar, önceki bir hesapla kullanıcı adı paylaşan yeni bir hesap kullanarak OneDrive veya SharePoint sitesine erişmeye çalıştığında, kullanıcılar aşağıdaki sorunlardan biriyle veya daha fazlasıyla karşılaşır:

  • "Erişim reddedildi" hata iletisi
  • Tutarsız bir kullanıcı deneyimi
  • Beklenen URL'ye https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1 (sonek bir sayı veya GUID olabilir) ekli yeni bir OneDrive sitesi

Neden

Bu sorunlar genellikle bir kullanıcı hesabı Microsoft 365 yönetim merkezi silinirse ve ardından silinen hesap tarafından kullanılan kullanıcı asıl adı (UPN) kullanılarak yeni bir hesap oluşturulursa oluşur. UPN aynı olsa bile yeni hesaba yeni bir kimlik değeri atanır. Ancak, hesapla ilişkili SharePoint ve OneDrive sitelerinin UserInfo listesinde yalnızca eski kimlik bulunur. Kullanıcılar yeni hesabını kullanarak bir SharePoint sitesine veya OneDrive sitesine erişmeye çalıştığında, yeni kimlikleri UserInfo listesindeki kimlikle eşleşmiyor. Bu nedenle, siteye erişimi reddedilir.

Bu sorunlar, Active Directory kuruluş birimi (OU) ile SharePoint arasında dizin eşitlemesi sırasında da oluşabilir. Kullanıcılar SharePoint'te zaten oturum açtıysa ve daha sonra farklı bir OU'ya taşındıysa, OU SharePoint ile eşitlendiğinde bu sorunlarla karşılaşabilir.

Çözüm

Bu sorunları düzeltmek için, SharePoint yönetici hesabı kullanarak Site Kullanıcısı Uyuşmazlığı tanılamasını çalıştırın.

Not

  • Bu tanılama, GCC High veya DoD ortamları veya 21Vianet tarafından sağlanan Microsoft 365 için kullanılamaz.
  • Yöneticiler OneDrive sitelerindeki sorunları gidermek için tanılamayı çalıştırmadan önce, yeni kullanıcı hesabının UserName değerinin eski hesapla eşleştiğinden emin olmaları gerekir. Yöneticilerin daha önce başka bir kullanıcı hesabına ait olabilecek OneDrive sitelerine bağlanması yasaktır. 
  • Tanılama, OneDrive sitesiyle ilgili bir sorunu başarıyla çözdüyse değişikliklerin gerçekleşmesi yaklaşık 24 saat sürebilir. Bu süre, OneDrive kutucuğunu doğru siteye işaret eden şekilde güncelleştirmeyi ve diğer OneDrive sitelerini geri dönüştürmeyi içerir.

Microsoft 365 yönetim merkezi tanılamayı doldurmak için aşağıdaki Testleri Çalıştır düğmesini seçin. Tanılama, SharePoint ve OneDrive sitelerine erişmeye çalışan iç kullanıcılar ve konuklar için çok çeşitli doğrulamalar gerçekleştirir.

İstendiğinde aşağıdaki bilgileri girin:

  • Etkilenen kullanıcı hesabı, örneğin UserA@contoso.com
  • Özgün site URL'si, örneğin https://contoso-my.sharepoint.com/personal/UserA_Contoso_com

Özgün OneDrive sitesi URL'sini almak için şu adımları izleyin:

  1. Bir yönetici hesabı kullanarak OneDrive sitesinde oturum açın.
  2. Sağ üst köşedeki Ayarlar (dişli) simgesini seçin.
  3. OneDrive Ayarları'nı ve ardından Diğer Ayarlar'ı seçin.
  4. Tanılama Bilgileri bölümünden OneDrive Web URL'sini kopyalayın.

Birden çok OneDrive URL'sini almak için, kuruluşunuzdaki kullanıcılar için OneDrive URL'lerini görüntüleme'deki yöntemlerden birini kullanın.

Genel senaryolar

Site Kullanıcısı Uyuşmazlığı tanılaması, silinen bir hesap tarafından kullanılan UPN kullanılarak yeni bir hesap oluşturulduğunda ortaya çıkabilecek aşağıdaki yaygın sorunları düzeltebilir.

Kullanıcı, beklenen URL'ye ekli bir sonek içeren yeni bir OneDrive sitesine yönlendirilir

Yeni bir kullanıcı hesabı oluşturulduğunda, yeni bir OneDrive sitesi atanır. Bir kullanıcı hesabı silindiğinde, hesaba atanan OneDrive sitesi hemen silinmez. Bu nedenle, silinen bir hesabın UPN'si kullanılarak yeni bir kullanıcı hesabı oluşturulursa, yeni hesaba atanan yeni OneDrive sitesi, ek bir son ek ile birlikte eski OneDrive sitesiyle aynı URL'ye sahiptir. Bu sonek bir sayı veya GUID'dir.

Yeni kullanıcı hesabının eski hesaba atanmış aynı OneDrive sitesini kullanmasını istiyorsanız, tanılama kullanıcıya özgün sitenin sahipliğinin atanıp atanamayacağını denetler. Kullanıcının izinlerini başarıyla doğruladıktan sonra tanılama, kullanıcıyı özgün sitesine yeniden bağlamayı ve son https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1eki olan yeni etkin siteyi geri dönüştürmeyi önerir.

Yeni OneDrive sitesindeki içeriğe daha sonra erişmeniz gerekiyorsa, silinen OneDrive'ı geri yükleyebilirsiniz.

OneDrive sitesine erişim reddedildi

Yeni bir hesap oluşturulduktan sonra kullanıcının eski OneDrive sitesine erişimi reddedilirse, tanılama kullanıcının profilini yeniden yapılandıracaktır. Ardından, erişim sorununu düzeltmek için kullanıcıyı eski OneDrive sitesine yeniden bağlayacaktır.

Not

Yöneticiler, OneDrive sitesinin sahiplerini el ile güncelleştirerek veya OneDrive sitesiyle ilişkili kullanıcı profili özelliklerini düzenleyerek bu sorunu çözemez. Tanılama, bu sorunu çözmek için önerilen tek çözümdür.

SharePoint sitelerinde veya kullanıcıya ait olmayan OneDrive sitelerinde kullanıcı kimliği uyuşmazlığı

Tanılama, UserInfo listesinde bir kullanıcı kimliği uyuşmazlığı algıladığında, eski kimliği kaldırmayı önerir. Teklifi kabul ettikten ve eski kimlik kaldırıldıktan sonra, yeni kullanıcı hesabına SharePoint sitesine uygun izinleri atayın.

Not: Bu sorunu el ile düzeltmek istiyorsanız, eski kullanıcı hesabını UserInfo listesinden kaldırmanız ve ardından yeni kullanıcı hesabına izinler vermelisiniz.

Daha Fazla Bilgi

SharePoint ve OneDrive'daki erişim sorunları hakkında daha fazla bilgi için bkz . SharePoint Online ve OneDrive'da "Erişim Reddedildi" veya "İzin gerekiyor" hataları.