Aracılığıyla paylaş


AADSTS7000222 - BadRequest veya InvalidClientSecret hatası

Bu makalede, Bir Microsoft Azure Kubernetes Service (AKS) kümesi oluşturmaya veya yükseltmeye çalıştığınızda oluşan hatayı (BadRequest veya InvalidClientSecret) tanımlama ve çözme AADSTS7000222 adımları anlatılmaktadır.

Önkoşullar

Belirtiler

AKS kümesi oluşturmaya veya yükseltmeye çalıştığınızda aşağıdaki hata iletilerinden birini alırsınız.

Hata kodu İleti
BadRequest ServicePrincipalProfile'daki kimlik bilgileri geçersizdi. Daha fazla bilgi için lütfen bakın https://aka.ms/aks-sp-help . (Ayrıntılar: adal: Yenileme isteği başarısız oldu. Durum Kodu = '401'. Yanıt gövdesi: {"error": "invalid_client", "error_description": "AADSTS7000222: '<application-id>' uygulaması için sağlanan istemci gizli anahtarlarının süresi doldu. Uygulamanız için yeni anahtarlar oluşturmak için Azure portalını ziyaret edin veya https://aka.ms/NewClientSecreteklenen güvenlik için sertifika kimlik bilgilerini kullanmayı göz önünde bulundurun: https://aka.ms/certCreds."
InvalidClientSecret Müşteri kimlik doğrulaması kiracı için geçerli değil: <tenant-id>: adal: Yenileme isteği başarısız oldu. Durum Kodu = '401'. Yanıt gövdesi: {"error": "invalid_client", "error_description": "AADSTS7000222: '<application-id>' uygulaması için sağlanan istemci gizli anahtarlarının süresi doldu. Uygulamanız için yeni anahtarlar oluşturmak için Azure portalını ziyaret edin veya https://aka.ms/NewClientSecreteklenen güvenlik için sertifika kimlik bilgilerini kullanmayı göz önünde bulundurun: https://aka.ms/certCreds."

Neden

Bu hizmet sorumlusu uyarısını oluşturan sorun genellikle aşağıdaki nedenlerden biri nedeniyle oluşur:

  • İstemci gizli dizisinin süresi doldu.

  • Yanlış kimlik bilgileri sağlandı.

  • Hizmet sorumlusu, aboneliğin Microsoft Entra Id kiracısı içinde mevcut değildir.

Nedenini doğrulama

AKS kümenizin hizmet sorumlusu profilini almak ve hizmet sorumlusunun son kullanma tarihini denetlemek için aşağıdaki Azure CLI kodunu çalıştırın:

SP_ID=$(az aks show --resource-group <rg-name> \
    --name <aks-cluster-name> \
    --query servicePrincipalProfile.clientId \
    --output tsv)
az ad app credential list --id "$SP_ID"

Alternatif olarak, hizmet sorumlusu adının ve gizli dizisinin doğru olduğunu ve süresinin dolmadığını doğrulayabilirsiniz. Bunun için aşağıdaki adımları izleyin:

  1. Azure portalında Microsoft Entra Id'yi arayın ve seçin.

  2. Microsoft Entra Id'nin gezinti bölmesinde Uygulama kayıtları'ı seçin.

  3. Sahip olunan uygulamalar sekmesinde etkilenen uygulamayı seçin.

  4. Hizmet asıl adını ve gizli dizi bilgilerini bulun ve bilgilerin doğru ve güncel olduğunu doğrulayın.

Çözüm

  1. AKS kümesinin kimlik bilgilerini güncelleştirme veya döndürme makalesinde, aşağıdaki makale bölümlerinden birinde yer alan yönergeleri uygun şekilde izleyin:

  2. Yeni hizmet sorumlusu kimlik bilgilerinizi kullanarak, bu makalenin AKS kümesini hizmet sorumlusu kimlik bilgileriyle güncelleştirme bölümündeki yönergeleri izleyin.

Daha Fazla Bilgi

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.