SLA özellikli bir varlık içeren yönetilen çözüm silinemiyor
Bu makalede, Dynamics 365 Müşteri Hizmetleri'nde hizmet düzeyi sözleşmesi (SLA) etkinleştirilmiş bir varlık içeren yönetilen çözümü silememe sorununa yönelik bir çözüm sağlanır.
Belirtiler
SLA'nın etkinleştirildiği bir varlığı içeren yönetilen çözümü silemezsiniz. Bu varlık daha önce içe aktarılan bir çözümün parçası olarak oluşturulmuştur.
Neden
Bir varlıkta etkinleştirildikten sonra SLA devre dışı bırakılamaz.
Sorunu anlamak için bu örneği kullanın:
- Org1 içinde yeni bir çözüm oluşturun ve Alan çözümü olarak adlandırın.
- Alan çözümü içinde yeni bir varlık oluşturun ve Alan işi olarak adlandırın.
- Alan çözümünü yönetilen bir çözüm olarak dışa aktarın.
- Alan çözümünü Org2 adındaki yeni kuruluşa aktarın.
İleri:
- Org1 içinde başka bir çözüm oluşturun ve Delta Alanı çözümü olarak adlandırın.
- Alan işi varlığını Delta Alanı çözümü ile ilişkilendirin. Varlıkta SLA'yı etkinleştirin.
- Delta Alanı çözümünü yönetilen bir çözüm olarak dışa aktarın.
- Delta Alanı çözümünü Org2 içine aktarın.
Şimdi, Delta Field çözümünü Org2'den silmeye çalışırsanız, SLA'nın etkinleştirildiği kendisiyle ilişkilendirilmiş bir Alan çalışma varlığı olduğundan bu çözümü silemezsiniz.
Çözüm
SLA özellikli bir varlık içeren bir yönetilen çözümü silmek için, öncelikle varlık girişini oluşturan önceden içe aktarılmış yönetilen çözümü silmeniz gerekir. Bu eylem varlık girişinin silinmesini sağlar. Daha sonra varlığı yeniden oluşturabilir veya yönetilen çözümün yeniden aktarabilirsiniz.
Kuruluş2'de Delta Alanı çözümünü silmek için önce Alan çözümünü silin.
Alan çözümü silinebilir çünkü onunla ilişkilendirilmiş varlık (Alan çalışması) SLA etkin değildir. Alan çözümünü silme, hem SLA yapılandırmasının hem de varlığın silinmesini sağlar.
Not
Kullanıma hazır varlıkları veya bunlarla ilişkilendirilmiş hazır varlıkları olan yönetilen çözümleri silemediğiniz için bu geçici çözüm kullanıma hazır varlıklar için çalışmaz.