虛擬機上的「FSLogix_unsupported_environment」和 OneDrive 同步處理 錯誤
徵狀
在使用 FSLogix 設定的虛擬機上,OneDrive 同步處理 客戶端無法同步處理,而且您會收到下列錯誤訊息:
OneDrive 無法同步處理
請連絡您的系統管理員以取得協助。
錯誤碼:FSLogix_unsupported_environment
此外,OneDrive 同步處理 用戶端會在您關閉錯誤訊息視窗之後關閉。
原因
發生此問題的原因是在使用 FSLogix 2009 Hotfix 1 之前的 FSLogix 版本的虛擬機上封鎖 OneDrive 同步處理 用戶端。 Microsoft 不再支持這些舊版。
解決方案
若要修正此問題,請在使用 OneDrive 同步處理 用戶端的所有虛擬機上下載並安裝最新版的 FSLogix。
其他相關資訊
系統管理員可以使用下列其中一種方法來檢查在其環境中執行之虛擬機上的 FSLogix 版本。
檢查多部虛擬機上的 FSLogix 版本
注意: 下列 PowerShell 腳本依原狀提供,且不受 Microsoft 支援。
使用 FSLogix 版本驗證 腳本。
檢查一部虛擬機上的 FSLogix 版本
使用 FSLogix FRX 命令列工具:
C:\Program Files\FSLogix\Apps\frx.exe version
執行下列 PowerShell 命令以取得
InstallVersion
FSLogix 登入機碼的 屬性:(Get-ItemProperty -Path HKLM:\SOFTWARE\FSLogix\Apps).InstallVersion
執行下列 PowerShell 命令,以取得安裝在系統上的 Microsoft FSLogix Apps 版本:
$uninstallPath = "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall" $appCheck = Get-ItemProperty -Path $uninstallPath\* | Where-Object { $_.DisplayName -eq "Microsoft FSLogix Apps" } ($appCheck | Where-Object {$_.EstimatedSize -eq ($appCheck | Measure-Object -Maximum EstimatedSize).Maximum}).DisplayVersion