錯誤 AADSTS50105 - 未將已登入的使用者指派至應用程式的角色
本文提供與 entra 識別符同盟 Microsoft驗證期間所發生之AADSTS50105錯誤的解決方案。
注意
本篇文章實用嗎? 您的輸入對我們很重要。 請使用此頁面上的 [ 意見反應 ] 按鈕,讓我們知道這篇文章為您運作得有多好,或我們如何加以改善。
徵兆
當您嘗試使用 SAML 型單一登入 (SSO) 登入已設定為使用 Microsoft Entra ID 進行身分識別管理的應用程式時,您會收到下列錯誤訊息:
錯誤AADSTS50105 - 登入的使用者未指派給應用程式的角色。
原因
尚未將 Microsoft Entra ID 中應用程式的存取權授與使用者。 用戶必須屬於指派給應用程式的群組,或直接指派。
注意
不支援巢狀群組,而且群組必須直接指派給應用程式。
解決方法
若要直接將一或多個使用者指派給應用程式,請參閱快速入門:將使用者指派給應用程式。
相關資訊
如需 Active Directory 驗證和授權錯誤碼的完整清單,請參閱 Microsoft Entra 驗證和授權錯誤碼。
與我們連絡,以取得說明
如果您有問題或需要相關協助,請建立支援要求,或詢問 Azure community 支援。 您也可以向 Azure 意見反應社群提交產品意見反應。