共用方式為


數據重新整理失敗,並略過數據流重新整理

注意

我們已於 2023 年 9 月 1 日合併並重新命名 Dynamics 365 Marketing 和 Dynamics 365 Customer Insights。 Dynamics 365 Marketing 現在稱為 Dynamics 365 Customer Insights - Journeys。 Dynamics 365 Customer Insights 現在稱為 Dynamics 365 Customer Insights - Data。 如需詳細資訊,請參閱 Dynamics 365 Customer Insights 常見問題

本文提供在 Dynamics 365 Customer Insights - Data Microsoft 中無法順利重新整理 Power Query 數據源的問題解決方案。

徵兆

Power Query 數據源處理狀態為 [已完成且發生錯誤],您會收到下列錯誤訊息:

系統觸發的重新整理成功;不過,數據流重新整理已略過,因為系統重新整理設定不適用於此數據源。 如果您想要定期重新整理此資料源,請透過 [編輯重新整理設定] 選項來設定排程的重新整理。

原因

Dynamics 365 Customer Insights - 數據有兩個重新整理選項: 系統重新整理數據源重新整理。 Power Query 型重新整理是由每個數據源的擁有者所設定。 系統會由系統管理員設定系統重新整理,並控制數據源和下游程序的其餘部分。

錯誤訊息表示 Customer Insights 中的系統重新整理不會重新整理 Power Query 數據源,但只會複製數據源的先前狀態。

解決方法

若要解決此問題, 請編輯數據源設定,以設定Power Query資料源的重新整理排程。