「Delta Lake 擷取作業無法取得版本」錯誤
注意
我們已於 2023 年 9 月 1 日合併並重新命名 Dynamics 365 Marketing 和 Dynamics 365 Customer Insights。 Dynamics 365 Marketing 現在稱為 Dynamics 365 Customer Insights - Journeys。 Dynamics 365 Customer Insights 現在稱為 Dynamics 365 Customer Insights - Data。 如需詳細資訊,請參閱 Dynamics 365 Customer Insights 常見問題。
本文可協助您解決「Delta Lake 擷取作業無法取得版本」錯誤,當您連線到儲存在 Delta 格式的數據時,Microsoft Dynamics 365 Customer Insights - Data。
徵兆
Dynamics 365 Customer Insights 中的 Delta 數據源 - 數據會嘗試連線到使用需要 Databricks minReaderVersion
或 3
更新版本之功能的數據表。 在此情況下,下列錯誤訊息會出現在 [數據源 ] 頁面上:
Delta Lake 擷取作業無法取得 DataSourceId> 版本<。
當您檢視數據表中的數據行時,會出現「無法儲存數據源架構」錯誤。
原因
Dynamics 365 Customer Insights - 數據支援具有 minReaderVersion
2
或更早版本的 Databricks 功能。 不支援需要 Databricks 讀取器版本或更新版本的 3
Databricks 功能。
解決方法
若要解決此問題,請從 Databricks 安裝中移除此功能,並將 還原 minReaderVersion
為 2
。 如需詳細資訊,請參閱 支援的 Databricks 功能和版本。