在 Microsoft Dynamics 365 App for Outlook 中開啟電子郵件時,檢視無法使用錯誤
本文提供解決方案來解決 當您嘗試 Microsoft在 Dynamics 365 App for Outlook 中開啟電子郵件時所發生的檢視無法使用 錯誤。
適用於: Microsoft Dynamics CRM Online
原始 KB 編號: 4338690
徵兆
在 Microsoft Dynamics 365 App for Outlook 中開啟電子郵件時,您會看到下列錯誤:
「檢視無法使用。 請連絡您的系統管理員。」
原因
如果您停用 Microsoft Dynamics 365 App for Outlook 所使用的其中一個檢視,就會出現此錯誤。 Microsoft Dynamics 365 For Outlook 應用程式會使用特殊窗體來顯示潛在客戶(Outlook 潛在客戶快速檢視應用程式)或聯繫人(Outlook 聯繫人快速檢視應用程式)資訊。 每個表單都包含參考特定檢視的清單。 如果停用其中一個 檢視,您可能會看到檢視無法使用 錯誤。
解決方法
請確定 Outlook 潛在客戶快速檢視表單和 Outlook 聯繫人快速檢視表單的應用程式所使用的檢視未停用。 當您在 Microsoft Dynamics 365 App for Outlook 中檢視電子郵件時,所使用的表單取決於電子郵件是否來自潛在客戶或聯繫人。 如果您只有在電子郵件來自聯繫人時才會看到此錯誤,您可能只需要修正聯繫人窗體所使用的檢視。 如果您只在電子郵件來自潛在客戶時看到錯誤,您可能只需要修正潛在客戶表單所使用的檢視。 在下列範例中,我們將確認App for Outlook連絡人快速檢視表單所使用的預設檢視已啟動。 對於在潛在客戶實體底下找到的 Outlook 潛在客戶快速檢視表單,您可以使用類似的步驟,而不是聯繫人實體:
- 身為具有系統管理員或系統自定義者安全性角色的用戶,開啟 Microsoft Dynamics 365 Web 應用程式。
- 流覽至 [設定],然後選取 [自定義]。
- 選取自訂系統。 這會開啟 [ 默認解決方案] 對話框。
- 選取 [實體],選取 [聯繫人],然後選取 [ 表單]。
- 開啟 Outlook 聯繫人快速檢視表單的應用程式。 根據預設,此表單包含兩個活動清單、商機清單,以及案例的清單。 下表顯示清單的預設名稱,以及用於清單的默認檢視。
- 您可以使用這些資料表作為重新啟用預設檢視的參考。
- 在此範例中,我們將查看來自 Activity 實體的前兩個清單。 您可以針對其他提及的實體重複相同的步驟。
- 切換回 [默認解決方案] 對話框,選取 [ 活動],然後選取 [ 檢視]。
- 選取 [ 檢視] 下拉式清單,然後選取 [ 非使用中的公用檢視]。
- 確認 [下一個活動] 和 [上次活動] 檢視不會出現在 [非作用中的公用檢視] 清單中。 如果停用上述任何檢視,請選取它們,然後選取 [ 啟用]。
- 使用相同步驟來確認其他檢視是否作用中之後,請選取 [ 發佈所有自定義專案]。
- 您可能需要關閉並重新開啟 Outlook,並可能清除瀏覽器快取。
Outlook 應用程式聯繫人快速檢視
清單名稱 | 預設檢視表 | Entity |
---|---|---|
下一個活動 | 下一個活動 | 活動 |
上次活動 | 上次活動 | 活動 |
最近的商機 | 互動中心表單的最新商機 | 機會 |
最近的案例 | 我的使用中案例 | 大小寫 |
Outlook 潛在客戶快速檢視表單的應用程式
清單名稱 | 預設檢視表 | Entity |
---|---|---|
下一個活動 | 下一個活動 | 活動 |
上次活動 | 上次活動 | 活動 |
利害關係人 | 所有項目關係人 | 連線 |
競爭者 | 所有競爭對手(摘要) | Competitor |
注意
如果您想要變更這些表單所使用的檢視,而不是啟用預設檢視,您可以在表單上開啟清單區段的屬性,以變更選取的檢視。 如果您已停用其中一個默認檢視,即使清單目前仍在參考該默認檢視,您仍無法看到清單所參考的檢視。 相反地,它會顯示一些其他使用中檢視名稱。 您可能需要先將它變更為另一個檢視,然後將其變更為您想要選取的檢視,讓變更生效。
Microsoft瞭解您嘗試變更檢視時可能會遇到錯誤的問題。 您可以變更下一個活動與最後一個活動檢視,但在嘗試變更其他檢視時,您遇到錯誤(發生錯誤。請返回首頁,然後再試一次)。 Microsoft正在調查此問題的保護解決方案。