如果已指派多應用程式 kiosk 配置檔,使用者就無法登入 Windows
本文可協助您修正指派多應用程式 kiosk 配置檔時,用戶無法登入已加入 Microsoft Entra 的 Windows 10 計算機的問題。
徵兆
當使用者嘗試登入已加入Microsoft已加入 Entra 且已指派多應用程式 kiosk 配置檔的 Windows 10 計算機時,嘗試會在載入使用者配置檔之前立即失敗。
在此情況下,kiosk 設定檔登入類型Microsoft Entra 使用者 或 群組。 此外,Windows 10 計算機會使用本機帳戶,而且您會注意到 事件檢視器 記錄檔中的下列錯誤訊息:
Microsoft Entra ID - 作業記錄 (範例 1 - 透過條件式存取所需的 MFA):
記錄檔名稱:Microsoft-Windows-AAD/Operational
來源:Microsoft-Windows-AAD
日期: <時間戳>
事件標識碼:1098
工作類別:AadTokenBrokerPlugin 作業
層級:錯誤
關鍵詞:錯誤、錯誤
使用者: <使用者 SID>
計算機: <計算機名稱>
描述:
錯誤:0xCAA2000C要求需要用戶互動。
程序代碼:interaction_required
描述:AADSTS50076:由於系統管理員所做的設定變更,或因為您移至新位置,您必須使用多重要素驗證來存取 '00000003-0000-0000-c0000-000000000000000'。Microsoft Entra ID - 操作記錄 (範例 2 - 透過條件式存取所需的使用規定 (TOU):
記錄檔名稱:Microsoft-Windows-AAD/Operational
來源:Microsoft-Windows-AAD
日期: <時間戳>
事件標識碼:1098
工作類別:AadTokenBrokerPlugin 作業
層級:錯誤
關鍵詞:錯誤、錯誤
使用者: <使用者 SID>
計算機: <計算機名稱>
描述:
錯誤:0xCAA2000C要求需要用戶互動。
程序代碼:interaction_required
描述:AADSTS50158:未滿足外部安全性挑戰。 系統會將使用者重新導向至另一個頁面或驗證提供者,以滿足其他驗證挑戰。指定的存取權 - 系統管理紀錄:
記錄檔名稱:Microsoft-Windows-AssignedAccess/Admin
來源:Microsoft-Windows-AssignedAccess
日期: <時間戳>
事件標識碼:31000
工作類別:為目前使用者套用指派的存取權。
層級:錯誤
使用者: <使用者 SID>
計算機: <計算機名稱>
描述:
套用目前使用者的指派存取權時發生未指定的錯誤,註銷...
原因
這是依照設計的行為。
之所以發生此問題,是因為使用者是以需要使用者互動的條件式存取原則為目標。 例如,多重要素驗證(MFA)或使用規定(TOU)。
解決方案
若要修正此問題,請排除需要用戶互動的任何條件式存取原則中的 kiosk 使用者,例如 MFA 或 TOU。
如果已啟用 MFA 的 kiosk 使用者,請將其停用,因為多重應用程式 kiosk 模式案例目前不支援 MFA。