共用方式為


針對桌面流程執行佇列錯誤進行疑難解答

本文提供桌面流程執行期間所發生佇列式錯誤的背景和潛在解決方案。

適用於: Power Automate
原始 KB 編號: 5004537

徵兆

您的桌面流程可能無法使用錯誤碼 NoCandidateMachine 或錯誤詳細數據執行「找不到電腦執行桌面流程」。

您可能也會收到下列其中一個常見的子程式代碼:

原因

當沒有計算機可用時,Power Automate 會建立佇列來保存等候執行的桌面流程。 一旦計算機可供使用,系統會根據 優先順序 和要求時間選取下一個桌面流程執行。 如果自要求計算機后六小時后沒有機器可用,桌面流程將會逾時並失敗,並出現 NoCandidateMachine 錯誤碼。

如錯誤訊息中所述,此錯誤表示協調器找不到可執行桌面流程的可用計算機。 此錯誤會在桌面流程執行開始之前發生。

重要

Power Automate 會自動將並行桌面流程執行數目調整為支援的最大值。 機器執行佇列會遵循先入先出的方法,這表示收到的第一次執行是要執行的下一個回合。 如果所有可用電腦已達到最大同時工作階段數並且無法執行佇列中的下一個執行項目,則佇列會被封鎖,直到有電腦可用於執行佇列中的下一個執行。

SessionExistsForTheUserWhenUnattended

當您嘗試在登入桌面流程連線的使用者所在的目標計算機上執行自動桌面流程時,就會發生此錯誤。

解決方法

若要解決此問題,請註銷會話(鎖定的工作階段會導致此錯誤),並確認您未使用電腦上的相同使用者登入。

UnattendedUserSessionDisconnected

當您嘗試在目標計算機上執行自動桌面流程時,就會發生此錯誤,因為目標電腦上有使用者用於桌面流程連線的已中斷聯機會話。

解決方法

若要解決此問題,請註銷已中斷連線的會話,並確認您未使用計算機上的相同使用者登入。

UnattendedUserSessionLocked

當您嘗試在目標計算機上執行自動桌面流程時,就會發生此錯誤,因為目標計算機上已鎖定用戶用於桌面流程連線的會話。

解決方法

若要解決此問題,請註銷鎖定的會話,並確認您未使用計算機上的相同使用者登入。

AttendedUserSessionNotActive

當您嘗試在使用者會話鎖定或中斷連線的目標計算機上執行已出席的桌面流程時,就會發生此錯誤。 只有在計算機解除鎖定時,目前的使用者符合桌面流程連線中的計算機時,才能執行已出席的桌面流程流程。

解決方法

若要解決此問題,

  • 使用用於參與執行的使用者重新連線計算機,並讓計算機上的會話處於作用中狀態。
  • 確認您是以正確的計算機為目標。 若要這樣做,請開啟機器運行時間應用程式,然後選取 [在入口網站中 檢視計算機],以確認它是否將您帶到執行中的目標計算機。

AttendedUserNotLoggedIn

當連線中指定的使用者未登入目標計算機時,就會發生此錯誤。

解決方法

若要解決此問題,

  • 在機器上與用於參與執行的用戶連線,並讓計算機上的會話處於作用中狀態。
  • 確認您是以正確的計算機為目標。 若要這樣做,請開啟機器運行時間應用程式,然後選取 [在入口網站中 檢視計算機],以確認它是否將您帶到執行中的目標計算機。
  • 檢查連線中使用的認證,並確定它們是解除鎖定會話中使用的認證。 您可以輸入 whoami 任何命令提示字元來驗證您的身分識別。

注意

針對 AttendedUserSessionNotActiveAttendedUserNotLoggedIn 錯誤,請確認執行 Power Automate 服務 (UIFlowService) 的帳戶具有電腦上的遠端桌面許可權。 根據預設,Power Automate 服務會以 的形式執行 NT SERVICE\UIFlowService。 如果您未變更此專案,請確認 NT SERVICE\UIFlowService 位於 [遠端桌面使用者 ] 群組中。 若要這樣做,請移至 [ 啟動>執行],輸入 usrmgr.msc,選取 [群組],按兩下 遠端桌面使用者 群組,並確認帳戶已包含。 如果未包含,請包含它(這需要系統管理員許可權),然後重新啟動計算機。

UIFlowAlreadyRunning

當桌面流程已在機器上執行時,可能會在下列其中一種情況中發生此錯誤:

  • 您執行已出席或自動桌面流程,且電腦上的使用中會話數目已達到其限制。
  • 您嘗試為已登入的用戶開啟會話。

解決方法

若要解決此問題,請等候已執行的流程完成或 取消其父雲端流程執行

其他錯誤碼

如需執行桌面流程時可能發生的其他錯誤碼和減輕步驟的資訊,請參閱 執行已出席或自動桌面流程時發生錯誤碼。

其他相關資訊

如果未提供子程式代碼,請檢查是否:

  • 計算機群組中的所有計算機都離線。

    啟動電腦,並確定Power Automate Desktop 已正確安裝,並可與因特網通訊。

  • 機器群組是空的。

    在指派桌面流程執行之前,請確定您的計算機群組至少包含一部計算機。

  • 機器群組中的所有計算機會持續忙碌。

    如果計算機未及時挑選桌面流程,可能是因為配置的計算機資源無法充分調整以符合工作流程需求。 新增更多機器有助於分散工作負載。

  • 計算機因為網路(包括 Proxy 或防火牆)問題而無法連線。

    請與您的 IT 系統管理員合作,確定您的電腦可連線。

  • 此問題為暫時性。

    請嘗試在動作的設定中變更 重試原則

  • 計算機群組中的電腦或所有計算機都無法與桌面流程連線。

    請確定符合下列其中一項:

    • 您未嘗試在所有電腦登入的群組上執行自動流程。
    • 您並未嘗試在所有電腦註銷的群組上執行已參與的流程。
  • 計算機已無法使用。

    新增計算機,然後更新雲端流程中的桌面流程連線,以使用新的計算機。

如果您的執行佇列中有桌面流程的備份,因為上述其中一個原因,您可以使用桌面流程執行頁面上的 [取消父流程執行] 動作來取消父雲端流程執行,以大量取消您的桌面流程執行。 一旦解決您的計算機問題,您就可以重新啟動這些雲端流程。