Z 報表的資料對帳問題
錯誤碼:SYS103633
本文提供 dynamics 365 Commerce 總部 Microsoft中 Z 報表數據對帳問題的解決方案。
徵兆
- Z 報表上顯示的金額與計算語句上顯示的總計不符。
- 總部中的交易有不正確的明細專案數目,或交易的總行數與總計不符。
- 總部輪班中顯示的交易數目小於 Z 報表中的交易數目。
- 由於上述其中一個原因,語句張貼失敗。
原因
先前所述徵兆最常見的根本原因是通道資料庫中產生重複的交易標識碼。 重複的交易識別碼可能會因為下列原因而產生:
- 新式銷售點 (MPOS) 的本機資料庫記憶體已損毀。
- MPOS 具有離線模式中的某些交易,而且會使用無法存取離機資料庫的帳戶來重新啟用。
- 自訂與產生交易標識符相關的問題。
解決方法
通常,Commerce 依賴數位順序來產生循序交易標識符。 如果系統無法判斷是否有任何原因使用數位序列,就會產生重複的交易標識符。
若要修正重複的交易標識符問題,請建立支援票證來檢查是否可以修正事務數據。 在某些情況下,例如當總部沒有數據遺失時,就不可能或需要任何數據修正。
若要協助防止未來發生此問題,您必須啟用啟用 新的交易標識碼,以避免總部中的重複交易標識碼 功能。 此功能是在 Dynamics 365 Commerce 10.0.19 版Microsoft引進。 藉由確保為每個交易建立唯一的交易標識符,有助於防止建立循序交易標識碼。 如需此功能的詳細資訊,請參閱 防止重複的交易標識符。